ASCOM and the Astro-Physics V2 ASCOM Driver

Quick Start - For Experienced ASCOM Users:

Follow these steps to Install the Astro-Physics V2 ASCOM Driver

  1. Go to the ASCOM website and review the latest required Windows OS and DotNet updates (see OS system links in the Platform download box).
  2. After the above updates are complete, download and install the latest version of the ASCOM platform.
  3. Once the ASCOM Platform is installed, follow this link to Ray Gralak's ASCOM driver page.
  4. Download and install the latest beta version (it contains all the latest bug fixes and upgrades).
  5. Review the documentation and tutorial videos offered on his ASCOM driver page (see above link).
  6. Run the setup screen either directly through the installer or through Start => Programs => Astro-Physics => ASCOM Driver => Setup Telescope.
  7. In the ASCOM Telescope Chooser of your ASCOM client program, select "Astro-Physics GTO V2 Mount"

The ASCOM Platform and the Astro-Physics V2 ASCOM Driver will provide you with more comprehensive and fail safe control of your Astro-Physics GTO mount. We encourage you to use this interface for PC-based control of your mount!

For Those Requiring (or wanting) a Bit More Information:

NOTE: Links to third party sites were current at the time of webpage publication, but are not under the control of Astro-Physics.

ASCOM Standards for Astronomy - The ASCOM Initiative

What is ASCOM?

ASCOM (AStronomy Common Object Model) is a go-between to allow different software packages to talk to different pieces of astronomical equipment. The ASCOM platform provides a common language for all the software, and then each individual driver translates that common language into the specific command laguage needed to make the equipment do what we want it to do.

The ASCOM initiative began in 1999 as new mounts and CCD cameras, each with their own unique control systems came on the market. Bob Denny of DC3-Dreams and others realized the complexity of developing mount and camera control software that could be used with a wide variety of instruments. The task of software developers to keep up with new mounts, cameras, focusers, etc. as they came on the market, or to stay abreast of revisions to the code of existing equipment was an enormous (or more correctly: insurmountable) task. So, the ASCOM Initiative was born to establish, develop and promote a driver-client architecture just as the computer industry had done earlier with printers, cameras and other peripherals. For even more information, check the following link: About ASCOM.

Why should I use ASCOM and the Astro-Physics V2 ASCOM Driver?
The ASCOM platform and the AP V2 ASCOM driver are not required to run PulseGuide by Ray Gralak of Sirius Imaging, and they are certainly not required for control of the mount with the Astro-Physics GTO Keypad. However, the platform and driver are required for PEMPro (also by Ray Gralak), ACP (by DC3 Dreams), and other programs, and are extremely useful for anyone wishing to control their mount from an external Windows computer. Most advanced planetarium and telescope control software packages have an option to use the ASCOM platform, or else they require it outright. (Note that these options are referred to as "telescope" control, but the telescope is just along for the ride. It is the mount that is being controlled.) We recommend that you select the ASCOM interface if it is an option in your software. The ASCOM option will be called the Telescope API (Application Programming Interface) This API will then allow you to use the Astro-Physics V2 Driver. The ASCOM Platform and the AP V2 driver will provide you with more comprehensive and fail-safe control of your mount.

The Astro-Physics V2 driver has been developed for Astro-Physics by Ray Gralak of Sirius Imaging. Unlike the earlier driver, this V2 driver is now fully owned and supported by Astro-Physics. It has been through rigorous testing and is being treated as an on-going project. We thank Ajai Sehgal for the first driver, which he developed on his own. It was a monumental effort that has served our customers well for many years. The new V2 driver, however, is much more fully developed and takes advantage of the advances to the ASCOM platform. If you are currently using the old driver, we strongly suggest that you upgrade. Check out the Features of the Astro-Physics V2 Driver that differrentiate it from the earlier driver.

We also advise you to keep your ASCOM updated to the latest version. At the publication of this webpage, ASCOM is at platform 6SP1. This is a major upgrade from Platform 5.x. For a complete listing of the revisions to the standard, go to the ASCOM History Page.

Installing and Updating the ASCOM Platform, Astro-Physics V2 Driver and other Components
In order to use the Astro-Physics V2 driver, you will need to install these components which are discussed in further detail below:

  1. Current updates and Service Packs for your Windows Operating System [Windows 8: RTM, Windows 7: Service Pack 1, Windows Vista: Service Pack 2, and Windows XP: Service Pack 3 at time of website publication. If a later version is available to that shown above, use the later version.] Check updates via Windows Updater.
  2. Microsoft DotNet Framework [.NET Framework 3.5 Service Pack 1 (contains all earlier versions down to 2.0) is required] Check updates via Windows Updater.
  3. ASCOM Platform - Current Release and Updates
  4. Astro-Physics V2 Driver - Check for updates regularly.

Microsoft Windows OS and the Microsoft DotNet Framework:
The current release of the ASCOM platform is designed to work with the Microsoft DotNet Framework. It is important that you keep your computer current with the latest updates to the Operating System (i.e. Service Packs) and to the DotNet Framework. The ASCOM website has been pretty good about providing guidance here. As you install the ASCOM platform, you will be instructed which version of the Dot Net Framework is required, either in a warning dialog box as you attempt to install the software, or through instructions on the ASCOM download page. See the section below on the DotNet Framework for more detailed information. Please perform all System and DotNet upgrades BEFORE installing the ASCOM components!

IMPORTANT NOTE: For owners of Vista and Windows 7 based systems, you may need to turn off "User Account Control" from within Control Panel to successfully install and use the various ASCOM components, drivers and ASCOM client programs. This is a Microsoft issue and is not caused by the ASCOM platform or the Astro-Physics V2 Driver.

Installing or updating the ASCOM Platform.
If you are installing the platform for the first time, the installation is rather straight-forward once the necessary Windows and DotNet updates have beeen completed. If you are updating from an earlier platform version, pay special attention to any warnings or instructions that you see on the web page or in the installer program. The installer program will guide you. At an earlier date, it was recommended on the ASCOM site that you NOT uninstall earlier versions, but that recommendation has now been removed, and is apparently no longer valid. The only valid instruction that we can provide is to follow all instructions on the ASCOM website to the letter! To install, click the link below and click the download button on the respective web page. Also be sure to install the AP V2 driver after the full platform installation is finished as described in the instructions a bit further down.

PLEASE NOTE: Since it is important to use the latest versions of the platform, we provide the necessary links to the various web pages where the most current files can be found. Please add these pages to your favorites (bookmarks) and check regularly for updates!

ASCOM Platform 6SP1
Simply click the link above to go to the ASCOM website's home page. On the right hand side of the page is a Platform 6SP1 Download Box. Click the download button and follow the installer instructions to install the platform from the website. In a normal installation, you should then be instructed to proceed to the most recent update release of the platform. Be aware that the latest platform update may also require the latest DotNet upgrade. This is why we advise keeping your Windows Operating System and DotNet Framework updated.

AstroPhysics V2 Driver
This is a completely new driver conforming to the ASCOM V2 Standard. The link above takes you to Ray Gralak's apdriver page. To use this driver, ASCOM Platform 6SP1 or later must be installed. It may not work with earlier platforms. Ray's AP V2 driver page can also be accessed through the ASCOM website.

To install the driver, simply click the link under the "Latest Beta Version" heading (called beta version due to documentation, not driver) and either run the file or save it and run it later. The file's name will be: Astro-Physics V2 Setup v.5.xx.xx.exe and will be followed by the release date. You do not need to uninstall earlier versions of the driver, but please note the following if you are upgrading from a beta version of v.4.99.59 or earlier:

IMPORTANT CHANGE: In this version, the Settings file location has been moved to a common data directory so all users and processes can share the same settings file. This means that you will need to either re-enter your settings (e.g. Longitude/Latitude) or copy AP.INI from //My Documents/<your Name>/Astro-Physics/ASCOM to C:\Documents and Settings\All
Users\Application Data\Astro-Physics\ASCOM or equivalent folders on Windows Vista or Windows 7.

Ray's AP V2 driver page will also have the latest help documentation for the driver. Since the driver and the documentation are both ongoing works in progress, we suggest that you also bookmark this page and check back often for the latest versions.

Instructional Videos for the AP V2 ASCOM Driver - MPEG 4 movie files:
Installing the AP V2 Driver
Setting up your AP V2 Driver
Operating your Mount with the AP V2 Driver

Features of the Astro-Physics V2 ASCOM driver as compared to the v.4.1.xx driver:

Some Special Notes on using TheSky from Software Bisque
To use the ASCOM interface with TheSky planetarium software, you will need to install a plug-in. Instructions for this are on the ASCOM website at this link in the FAQ pages. Scroll down to the section entitled: 2. TheSky Controlling a Telescope With an ASCOM Driver. Use of ASCOM with TheSky 6 requires the TeleAPI v5.04 driver (or later) and TheSkyX requires the X2 v1.02 driver (or later). Both are available on the ASCOM website.

Old ASCOM
Since the ASCOM v.6SP1 Platform is not compatible with older computers with operating systems that predate Windows XP, we have also included links to the previous platform version and AP driver below. If you have a computer running Windows XP or later, we DO NOT recommend using the old platform and driver!

ASCOM Platform 4.1
Original ASCOM AP Driver

Back to Top

 


Microsoft .NET Framework

Some Important Notes on the Microsoft DotNet (.NET) Framework

To quote Wikipedia: " The Microsoft .NET Framework is a software framework that can be installed on computers running Microsoft Windows operating systems. It includes a large library of coded solutions to common programming problems and a virtual machine that manages the execution of programs written specifically for the framework. The .NET Framework is a Microsoft offering and is intended to be used by most new applications created for the Windows platform."
from: http://en.wikipedia.org/wiki/Dotnet_framework

There is, unfortunately, a great deal of confusion regarding the required DotNet updates. The ASCOM Platform 6SP1 only requires that .NET 3.5 SP1 be installed. Framework 3.5 SP1 contains all the earlier .NET Framework versions back to .NET 2.0. It needs to be noted that .NET Framework 4.0 does not contain the necessary versions and is not a substitute for 3.5 SP1. Windows 7 and Windows 8 already have the .NET Framework preinstalled and it is a part of the operating system. Do not attempt to install any downloadable version of the .NET Framework on those systems.

There have been some cases where the .NET Framework has become disabled on Windows 7 and 8. In that case, do not attempt to download and install the framework. Instead, go to Control Panel/Programs (or Add/Remove Programs) and select Turn Windows Features On or Off. In the dialog, make sure that .NET Framework 3.5.1 (on Windows 7) and .NET Framework 3.5 (on Windows 8) are enabled. After doing this, you must also use Windows Updater to install any additional updates.

If your computer has been set for Windows Automatic Updates, you may already have all of the necessary DotNet components on your computer. By far, the easiest way to get the correct components if you do not have the computer set for Windows Automatic Updates is to visit Windows Update on the web at http://www.update.microsoft.com/. Of course, it should be no surprise that Windows Update only works with Windows Internet Explorer and it requires Windows Installer 3.1 as well. If you wish for more control over the components you install, you will need to visit the .NET homepage and do a bit of research. We are not Microsoft, and cannot provide technical support for your Windows and DotNet upgrades.

Here are a few final words of caution provided as an example: In June of 2010, we decided to update an older Windows XP machine here at Astro-Physics. This machine only had .NET 1.1 and an early .NET 2.x (no service packs) installed. Rather than using Windows Update, we decided that we were smart enough to simply go to the .NET homepage and do it ourselves. We saw that the current version of .NET being promoted on the Microsoft site was .NET 4.0, so we downloaded and installed it thinking this would surely bring us up to date for the ASCOM Platform 5.0b and the 5.5.1 update. Oooops!! We ended up having to uninstall .NET 4.0 and then start over using Windows Update before we could successfully install the latest ASCOM platform.

We provide two examples from computers used for testing here at Astro-Physics: As of this writing in July,. 2010, both computers have been fully updated with Windows Update, and both have the latest ASCOM platform and AP V2 driver. The successful installation of the necessary .NET components on an XP SP3 machine shows the following programs in the Control Panel's Add/Remove Programs window:

On a Vista laptop, the Programs and Features window shows the following:

We repeat the "Important Note" from the Windows Section above: For owners of Vista and Windows 7 based systems, you may need to turn off "User Account Control" from within Control Panel to successfully install and use the various ASCOM components, drivers and ASCOM client programs. This is a Microsoft issue and is not caused by the ASCOM platform or the Astro-Physics V2 Driver.


Back to Top

Copyright © 2012, Astro-Physics, Inc. - All Rights Reserved
This page was last modified: February 4, 2013

Astro-Physics, Inc.
11250 Forest Hills Road, Machesney Park, IL  61115, U.S.A.
Phone: 815-282-1513   Fax: 815-282-9847